Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

The content's alignment is not proper inside modal window

SA-29012

Summary



In Internet Explorer, Attachment modal Window is not visible properly.

The buttons sometime work & sometimes not, Alignment of the content is not proper inside modal window though Out-of-the-box (OOTB) sections are used.


Error Messages



Not applicable


Steps to Reproduce



1. Open User Portal (Fixed portal type).
2. Select Attachment Icon which is on top of the Work Object.
3. Modal window with Select Attach file(s) option launched.


Root Cause



A defect in Pegasystems’ code or rules : Portals of type "fixed" is used in the scenario. Hence, the portal is launched in Internet Explorer 5 quirks mode.

The modal dialog rules are compatible with Standards mode. Hence the content is not aligned properly.


Resolution



Here’s the explanation for the reported behavior:

The portals of type "fixed" are deprecated in Pega 7. Below are the references to understand the same. To fix incompatible issue, Pega recommends to use composite portals.

Below are the PDN references:

 


 

Published October 21, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us