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Support Article

Correspondence email does not show attachment list

SA-75954

Summary



Correspondence email attached to a work object does not display when only one of multiple attachments is attached in the mail. However, the received email includes the attachment.


Error Messages



Not Applicable


Steps to Reproduce

  1. Configure an Outbound email server.
  2. Create a flow to the Send Correspondence email with attachments such that the attachment is based on the pyAttachmentKeys property.
  3. Add multiple attachments to the work object.
  4. Submit the flow. The receiver receives the attachments. However, the attachment does not display in the correspondence email attached to the work object. The correspondence email does not display the attachment list.


Root Cause



In the Show HTML rule, the attachments display when all the attachments are attached or a specific category is passed. However, for specific attachments, the attachment list does do not display. The HTML rule must be modified to display the attachments based on the pyAttachmentKeys property.


Resolution



Apply HFix-51893.

Suggest Edit

Published March 26, 2019 - Updated October 8, 2020

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