Support Article
Couldn't connect to MQ server located at USCINC2B5S8
SA-8000
Summary
Test Connectivity for Data-Admin-Connect-MQServer fails with the following Error message on screen.
Status
Fail
Message
Couldn't connect to MQ server located at USCINC2B5S8
<p>
com.ibm.mq.MQException: MQJE001: Completion Code '2', Reason '2495'.
Error Messages
Message
Couldn't connect to MQ server located at USCINC2B5S8
<p>
com.ibm.mq.MQException: MQJE001: Completion Code '2', Reason '2495'.
Steps to Reproduce
1) Make sure ibm MQ8.0 server is running with required Quemanager , chanel , queue and queue privileges
1) Create MQ Rule connect
2) Create MQ Server Service
3) Enter IBM MQ environment details properly
4) Test Connectivity
Root Cause
The root cause of this problem is environmental. MQ jar inconsistencies or mismatch between PRPC database and MQ Server.
Resolution
This issue is resolved by making the following change to the PRPC operating environment:
1) Stop the JBoss server.
2) Clean-up all prior MQ JAR entries from the PRPC database by executing the SQL command below for each of the MQ JARs that you installed.
DELETE from PRPC_SCHEMA_NAME.pr_engineclasses where pzjar like '%JAR_FILE_NAME.jar';
Replace JAR_FILE_NAME with the following jar file names -
* com.ibm.mq.commonservices
* com.ibm.mq.headers
* com.ibm.mq
* com.ibm.mq.pcf
* com.ibm.mq.jmqi
* com.ibm.mqjms
* fscontext
* jms
3) Re-start JBoss server, and install the following JAR obtained from the MQ server v8.0 filesystem into PRPC database via Designer studio > Application > Import wizard
* com.ibm.mq.allclient.jar
4) Re-start PRPC JVM/ JBoss server again.
Published June 12, 2015 - Updated October 8, 2020
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