Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

CPM - CTI creates multiple work items from one call

SA-14748

Summary



If a user logs in to one Pega JVM and logs off, again logs in to another Pega JVM, but does not log off the CTI link, then both the JVMs send the incoming call request to their respective desktop ActiveX control and create multiple work items. Therefore, multiple interactions start at the same time.


Error Messages



Not Applicable


Steps to Reproduce



1. Log in to a Pega JVM and log in to the softphone.
2. Log off without closing the CTI link.
3. Log in to a second Pega JVM.
4. Log in to the softphone and receive an incoming call. Two work items are created from the screenpop control.


Root Cause



A defect in Pegasystems’ code or rules where multiple work items are created for a single call.
Changes are required to allow to launch the softphone without user intervention on refresh, if user has already launched it from menu item.


Resolution



Apply HFix-23703 which provides revised versions of the following Rule components:-

* RULE-FILE-TEXT WEBWB PEGA_CPM_MENUACTIONS!JS
* RULE-FILE-TEXT WEBWB PEGA_CTI_CALLEVENTHANDLER!JS


If also installing HFix-23768, perform the same prior to installing HFix-23703.

Published January 31, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us