Support Article
CPM Dashboard Reports section refresh Issue
SA-32143
Summary
In Customer Process Manager (CPM) user portal and Case manager portal, when user is tries to add or copy or delete reports in the private category corresponding report count does not updates.
Error Messages
Not applicable
Steps to Reproduce
Rules Used to display:
1) In pyReportBrowserInner7 available section make a Save As of final rule pzRBCategoriesWrapper7 to replace it with RBCategoriesWrapper7.
2) Open Manager portal and click Reports.
3) Click on edit symbol in any public Category report.
4) Select Copy from the menu, pop-up will appear select private in the drop-down and Submit. Selected report will be moved to private category > My Report.
5) Check the count displayed in My Report. Count will mismatch with the actual reports present.
Root Cause
In pyReportBrowserInner7 available section pzRBCategoriesWrapper7 is replaced with RBCategoriesWrapper7 which is causing the issue.
The Out-of-the box (OOTB) copy option is looking for "pzRBCategoriesWrapper7" node name to refresh which it is not finding and refresh is not working as expected.
It should not be modified.
Resolution
Perform below local change to forcefully call pzRBForceDataPageRefresh Data Transform.
Add a new JS file and include it in pyCMReportBrowser7 Harness.
JS content:
$(document).on("click", function(event) {
setTimeout(function() {
if ($(event.target).attr("id") == "ModalButtonSubmit") {
//alert("Hi");
var newSectionEle = pega.u.d.getSectionByName("pyReportBrowserInner7", "", window.document.body);
pega.u.d.reloadSection(newSectionEle, "pzRBForceDataPageRefresh", "", false, true, "", false);
}
}, 2000)
});
Published January 12, 2017 - Updated October 8, 2020
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