Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

CPM social agents create repeated exception in log file

SA-24366

Summary



The log file is filled with connector exceptions associated with the CPM-Social agents.  These agents are out of the box and are not used in the application.


Error Messages



2016-05-31 14:22:59,777 [.PRPCWorkManager : 1] [ STANDARD] [ ] [ MyCoCA:07.13] (nvoke.Rule_Connect_REST.Action) ERROR - com.pega.pegarules.pub.services.ConnectorException: Caught unhandled exception: java.lang.IllegalStateException: Target host must not be null, or set in parameters.
2016-05-31 14:22:59,777 [.PRPCWorkManager : 1] [ STANDARD] [ ] [ MyCoCA:07.13] ( internal.mgmt.Executable) ERROR - Exception
com.pega.pegarules.pub.services.ConnectorException: Caught unhandled exception: java.lang.IllegalStateException: Target host must not be null, or set in parameters.


Steps to Reproduce



Not Applicable
 

Root Cause

These errors occur due to missing host configuration for the social agent.


Resolution

Disable the agent since is it not used in the application.

To configure this agent, refer to https://pdn.pega.com/documents/customer-process-manager-cpm-713-social-engagement-implementation-guide

Suggest Edit

Published June 17, 2016 - Updated December 2, 2021

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us