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Support Article

CPMUi ruleset is not getting populated

SA-46516

Summary



User has upgraded Pega Customer Service CPM 6.2 SP1 application to CRM 7.22.

When trying to 'Save As' rule into CPM-Portal class, the ruleset dropdown in 'Save-As' rule form is not getting populated with the desired application rulesets.



Error Messages



Not Applicable


Steps to Reproduce



Try to do 'Save As' of any rule into CPM-Portal class in CRM 7.22 environment.

Root Cause



An issue in the custom application code or rules.

CPM-Portal class is of ruleset CPM-UI at the user's side instead of PegaAppCA.

Class CPM-Portal was related to ruleset CPM-UI in prior versions of CPM 7.1 Release2. So the issue is because of CPM-Portal class didn't get re-imported properly during the upgrade process of CRM 7.22.

Resolution



Here’s the explanation for the reported behavior:

Reimport the whole jar or only CPM-Portal class(by enabling advanced mode) to resolve the issue.

Published March 23, 2018 - Updated December 2, 2021

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