Support Article
CTI creates multiple interactions on pop
SA-21100
Summary
Sometimes when a call is accepted multiple Interaction tabs with multiple interaction ids get created.
Error Messages
Not Applicable
Steps to Reproduce
- Place a call and get a screen pop.
- Either open an interaction by clicking accept on the pop, or set the call treatment to auto-accept
Root Cause
An issue in the custom application code or rules. In PRPC 6 a custom version of the out of the box activity CTIAcceptCall was created. It was moved forward unchanged to Pega 7 release. It is now incompatible with the current architecture. In particular, the custom version of CTIAcceptCall is calling CPMInvokeInteractionStartActivity.
Resolution
Perform the following local-change: Revert back to the out of the box version of CTIAcceptCall. If any customizations still need to be made, make sure they are compatible with the current architecture.
Tags:
Published March 23, 2016 - Updated October 8, 2020
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