Support Article
CTI Link Not working for Pega ML7 and CPM 7.13
SA-8528
Summary
In developer portal option PegaCALL Utilities => CTI Links, user created an instance of CTI Link. The UI is not showing Status Button and Test connectivity. Button is not showing connection success.
Error Messages
Not Applicable.
Steps to Reproduce
Product media for CPM 7.13 comes with a HFix-10149 - 713-Header_Mobile_CTI_Issues.
Root Cause
The team followed our following instructions, to make the CTI Link work for Pega ML7 with CPM 7.13:
- Unzip the cpm jar
- Import the pegachannelservices.jar thru GUI (and not thru prpcUtils)
- Truncate cache
- Empty the Temp Directory
- Restart JVM
The is related to the issue with prpcUtils script used to Import Jars, that is failing to Import jar that has embedded jars in it, for CPM upgrade. While a resolution was provided to unzip the jar and import, the resolution seems to not be working, unless we import the pegachannelservives.jar thru GUI.
Resolution
Install Hfix-10149 which is included in upgrade media and then reimport prchannelservices.jar.
Published June 12, 2015 - Updated December 2, 2021
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