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Support Article

CTIToolbar not refreshing on PegaCALL 721 with AACC

SA-32063

Summary



The CTI Toolbar is not functional as expected. Aftet the agent change the status, the toolbar does not get updated as expected and causing confusion to the agent. 
 

Error Messages



2016-11-24 12:46:58,143 [PegaWorkManager : 15] [ STANDARD] [ ] [ PegaRULES:07.10] ( internal.async.Agent) INFO - System date: Thu Nov 24 12:46:58 CET 2016 Total memory: 2,147,483,648 Free memory: 283,350,200 Requestor Count: 23 Shared Pages memory usage: 0%
2016-11-24 12:54:01,816 [ WebContainer : 2] [TABTHREAD2] [ ] [SystemUtils:01.01.01] (es_Session_CTILink_AACC.Action) ERROR a_host|aaa.bb.ccc.dd urca - Failed to log the user out of the CCT Server after successful User validate CCT User [ccaf] CCT Domain [testcorner] Error []
2016-11-24 12:54:02,481 [ WebContainer : 2] [TABTHREAD2] [ ] [SystemUtils:01.01.01] ( internal.mgmt.Executable) ERROR a_host|aaa.bb.ccc.dd|Rule-Connect-SOAP.ChannelServices-Session-CTILink-AACC.LoginAgentToState urca - Exception
com.pega.pegarules.pub.services.RemoteApplicationException: SOAP service failed
at com.pegarules.generated.activity.ra_action_invokeaxis2_93976f78c07f70c9109f99aa2efb36d6.step15_circum0(ra_action_invokeaxis2_93976f78c07f70c9109f99aa2efb36d6.java:3520)
at com.pegarules.generated.activity.ra_action_invokeaxis2_93976f78c07f70c9109f99aa2efb36d6.perform(ra_action_invokeaxis2_93976f78c07f70c9109f99aa2efb36d6.java:291)
at com.pega.pegarules.session.internal.mgmt.Executable.doActivity(Executable.java:3527)
at com.pegarules.generated.activity.ra_action_invoke_8171c74e56fb26f2c41f9a69e39e4099.step8_circum0(ra_action_invoke_8171c74e56fb26f2c41f9a69e39e4099.java:1037)
at com.pegarules.generated.activity.ra_action_invoke_8171c74e56fb26f2c41f9a69e39e4099.perform(ra_action_invoke_8171c74e56fb26f2c41f9a69e39e4099.java:189)
at com.pega.pegarules.session.internal.mgmt.Executable.doActivity(Executable.java:3527)
at com.pegarules.generated.activity.ra_action_loginagenttostate_4046cbc71c673c6156e0a893b87eddcc.step3_circum0(ra_action_loginagenttostate_4046cbc71c673c6156e0a893b87eddcc.java:392)
at com.pegarules.generated.activity.ra_action_loginagenttostate_4046cbc71c673c6156e0a893b87eddcc.perform(ra_action_loginagenttostate_4046cbc71c673c6156e0a893b87eddcc.java:104)
at com.pega.pegarules.session.internal.mgmt.Executable.doActivity(Executable.java:3527)
at com.pega.pegarules.session.internal.mgmt.Executable.invokeActivity(Executable.java:10674)
.....................
Caused by:
com.pega.apache.axis2.AxisFault: updatePassiveTerminal():Error - The passive terminal cannot be updated while the Agent[9406] is logged in.
at com.pega.apache.axis2.util.Utils.getInboundFaultFromMessageContext(Utils.java:531)
at com.pega.apache.axis2.description.OutInAxisOperationClient.handleResponse(OutInAxisOperation.java:375)
at com.pega.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:421)
at com.pega.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:229)
at com.pega.apache.axis2.client.OperationClient.execute(OperationClient.java:165)


Steps to Reproduce

  1. I do log into the Avaya server and the bar becomes red, showing the "Not Ready" status.
  2. I can logoff and the bar becomes inactive (the phone icon in the bar that shows the status)
  3. I cannot change status. I can execute the operations, but the CTI bar does not reflect any changes.
  4. If I refresh the bar, the changes are seen.
  5. An incoming call does not trigger any popup.
  6. I have used the Firefox debugger and I see that the browser is sending polling requests to the Avaya Server. And we get an answer.
  7. I have activated the tracer to trace only ChannelServices-Device-Phone-UI.Ready and I see it triggered when I try to change my status to ready.
  8. This activity completes succesfully and sends the variable local.Response to the browser (performs the Show-Property). The content of this variable at this time, after performing a Ready operation, is:
  9. {"pyPegaCTIError":"Good", "pyActivationComplete":"false", "pyAllowInteractionTRansfer":"false", "pxObjClass":"ChannelServives-Device-Phone-UI", "pyAutoLogin":"false", 


Root Cause



A defect or configuration issue in the operating environment. The PRPC Server where PegaCALL is running is using SSL, however the SSL module in AACC has not been enabled. 

Resolution



Enable SSL module in AACC.

 

Published January 17, 2017 - Updated December 2, 2021

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