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Support Article

Current System in Reporting area always jumps back to default

SA-37258

Summary



On the 'Autonomic Event Services' ('AES') portal it is possible to switch the context of the 'AES Manager' Portal to a particular ("monitored-node") system ; using the 'Current System' Drop-down, on the top-right of the Portal.
That means that any links clicked in the main Portal will use this context to display the appropriate information/report/chart for that selected node.

In certain circumstances (for instance when opening an item from the 'Reporting' function); this 'Current System' drop-down will 'reset' to the 'default system' when you return to the main screen.

This is problematic when there are many monitored nodes defined.

Error Messages



Not Applicable; there is no error - just wrong behaviour.


Steps to Reproduce



The following screenshots demonstrate the issue:

1. Login into to AES using 'AESManager'; switch the 'Current System' to something other than the default (this implies you must have more than one monitored node).





2.Click 'Reporting' from the left-hand side of the Portal, expand 'ACTION ITEM REPORTS' (in Main Portal); and select (say) 'Resolved Items'; this will bring up a report showing items that match this criteria.

[The important thing about this test; is that you have to select a report which contains at least one item - you'll need to 'click-through' that item at the next step]





3.From within the Report Window; select an item (click-through) - this will change the main Portal (in the background) to show the item details.




4. Click the 'Reporting' link again; this will take the Portal back to the initial screen - but the 'Current System' has 'flipped' back to the default; rather than retaining the previously selected context.




Note: The Item Screen also offers a 'clean' way to close an item - by clicking 'CLOSE' - this WILL preserve the context; but it is easy not to remember to do this each time; meaning that the end-user may get confused about which context they are looking at.

Root Cause



A defect in Pegasystems’ code or rules .

Resolution



Apply HFIX-33972; which is an AES specific HFIX - it is NOT a HFIX that is installable by Update Manager.

[ HFIX-33972.zip has the SHA1 checksum of: 07C91889DE346A26999270B82454EFE076AC84F9 ]

Published May 6, 2017 - Updated October 8, 2020

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