Support Article
Customer Service ruleset import hangs
SA-26913
Summary
Doing an install of Customer Service for Communications 7.21 on top of a fresh 7.21 platform.
While importing the Customer Service.jar, the user session appears hung, the PegaRULES log contains no error, and the import does not complete.
Error Messages
Not Applicable
Steps to Reproduce
- Import Customer Service.
- Press Next as applicable.
- System hangs without displaying the number of records page.
Root Cause
A defect or configuration issue in the operating environment.
Thread dumps from the hung import point to DatabaseDatabaseMetaData.getColumns() call hanging.
Most likely cause is that the DB user has DBA privileges and can look into other schemas which makes this metadata call expensive.
Resolution
Make the following change to the operating environment:
Install Customer Service jar on a Oracle instance with single schema.
OR
Make sure the DB user is set up for run time use according to the install guide:
https://pdn.pega.com/documents/pega-721-platform-installation-guide-oracle-weblogic-server-and-oracle
"Single-user configuration— Base user only Pegasystems recommends that user creates an Admin user separate from the Base user; however, if user opts for a single Base user, grant these permissions to the Base user: l CREATE SESSION l CREATE TABLE l CREATE PROCEDURE l CREATE VIEW l CREATE TYPE l CREATE TRIGGER"
Published September 8, 2016 - Updated December 2, 2021
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