Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Data exported as CSV does not support Thai characters



A table is delegated for business and the Export and Import CSV is used as the main feature. On downloading the file from the Pega application, Thai characters display incorrectly.

Error Messages

Not Applicable

Steps to Reproduce

  1. Create a table using the Data Table wizard.
  2. Input Thai characters in the table.
  3. Export the table using the Export link.
  4. Open the CSV file in Microsoft Excel.

Root Cause

Thai characters did not display due to encoding issues.


Here's the explanation for the reported behavior:

Microsoft Excel does not allow the data to be saved as a CSV file in Unicode. The data must be saved as Unicode text and all the tabs with commas (,) must be converted using a Text editor such as Notepad++.

To leverage the existing functionality, edit using Text editor such as Notepad++ instead of using Excel to edit data with multi-byte characters.

Additionally, to view the exported data in Excel, perform the below steps instead of opening the file directly in Excel,
  1. Open Excel file.
  2. Navigate to the Data tab.
  3. Obtain the external data in XML format.
  4. Select the file.
  5. Select the Delimiter option as comma and import it. Thai characters display correctly in Excel.

Published August 19, 2019 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us