Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Data loss when failed offline case is routed to error workbasket

SA-57933

Summary



Data loss occurs when an offline case fails Sync and is routed to an error workbasket.


Error Messages



Not Applicable.


Steps to Reproduce

  1. Log in to the application
  2. After a case fails Sync, check the error workbasket
  3. Open the case and verify the data integrity


Root Cause



When a sync issue occurs while processing the actions, the case is moved to the configured error sync workbasket or the default work basket. The last instance of the pyWorkPage of the failed case has all the data till the failed assignment. However, after pyWorkPage diff changes, only changed data is sent. When a sync error happens, only the pyWorkPage of the last failed assignment is saved. All the data submitted in the earlier actions is lost.


Resolution

Apply HFix-43967.


 

Published July 23, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us