Support Article
Database connection not available ConnectionWaitTimeoutException
SA-36743
Summary
Thread dumps cause slowness and JVM crash.
Error Messages
2017-04-14 16:08:19,017 [j2ee14_ws,maxpri=10]] [ STANDARD] [ PegaRULES:06.02] ( internal.access.DatabaseImpl) ERROR - There was a problem with the database when getting a list:
com.pega.pegarules.pub.database.ConnectionException: Database-General Problem encountered when getting connection for database pegarules 0 Connection not available, Timed out waiting for 180002
From: (B55EA34AA62120FD75844EC84C204F7BF)
Caused by SQL Problems.
Problem #1, SQLState null, Error code 0: com.ibm.websphere.ce.cm.ConnectionWaitTimeoutException: Connection not available, Timed out waiting for 180002
at com.pega.pegarules.data.internal.access.ExceptionInformation.createExceptionDueToDBFailure(ExceptionInformation.java:163)
at com.pega.pegarules.data.internal.access.ConnectionManagerImpl.getConnection(ConnectionManagerImpl.java:1352)
Steps to Reproduce
Perform a load test with a high volume of requestors.
Root Cause
A defect or configuration issue in the operating environment
A very high volume of requestors causes an insufficient number of connections to be available in the connection pool.
Resolution
Perform the following local-change to increase the number of connections in the WebSphere Application Server:
- Set the Maximum Connections value to be higher, based on the environment needs in the WebSphere Application Server Admin Console, Resources > JDBC > Data Source.
- Go to IBM Support and search on swg21573982 to find the release note titled Default maximum connections size is too small in IBM Business Process Manager (BPM) 7.5
Published May 5, 2017 - Updated October 8, 2020
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