Support Article
Database-NonexistentTable errors in log post update to 7.2.2
SA-38294
Summary
User has recently upgraded from Pega 7.1.9 to Pega 7.2.2.
After the upgrade was done they noticed that thousands of Database-NonexistentTable Exception in Log-file.
These exceptions are mainly on Pega Out-of-the-box (OOTB) Classes which are mapped to some Database tables (names are often appended by vague numbers).
But these Database Tables do not exist in the Database.
Error Messages
In the logs they have many Database nonexistent table exceptions related to their custom and OOTB tables, one such is shown below:
Database exception while retrieving the database table information for class History-Acord-AdditionalInterestInfo_Type
com.pega.pegarules.pub.database.NonexistentTableException: Database-NonexistentTable dbo.pr_History_Acord_Additio_81afc PegaDATA
Steps to Reproduce
Upgrade from Pega 7.1.9 to Pega 7.2.2.
Root Cause
A defect or configuration issue in the operating environment.
Resolution
Apply HFix-34509. However this fix is only for the OOTB tables, for custom tables manually should be deleted from pr4_base table.
Published June 12, 2017 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.