Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Date format in Calendar is not correct



Date format in Calendar is not correct. It happens only when we set locale as "ja_JP".
Expected: MM/DD
Actual: YY/MM

Error Messages

Default Locale: 

Locale set to Japanese language:

Steps to Reproduce

1. Edit operator locale to "ja_Jp".
2. Launch case manager portal.
3. Click on calendar button, In the content section of calendar click on weekly button.
4. Notice the issue highlighted above.

Root Cause

While displaying the date in the calendar for weekly option, we were truncating the date to the first 4 units(thought to be separating out the year). But this will cause issues with other locales such as Japanese where the format is yy/mm/dd instead of dd/mm/yy. Removing this truncating logic will fix the issue.


Acceptance: New Hotfix
Hotfix Details: HFix-26721
HotFix Dependencies: No Dependent Hotfixes

Rule Changes:


Published March 23, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us