Support Article
Date Format Issue in Export to Excel
SA-3940
Summary
Whenever user try to export the results of a report which contains the date as a column, the date format is getting changed in the excel. This issue is not observed in 5.4
Windows machine Regional settings as English(United States)
No locale is specified on Operator ID record.
Error Messages
We are not getting any error message.
Steps to Reproduce
1. Create a report with date as a column.
2. Run the report and click on export to excel once the results are retrieved.
3. Compare the date format between the Pega UI screen and the excel.
4. The date format will be changed in the excel.
Root Cause
The root cause of this problem is software use/operation error.
When performing an export to excel from listview the default presentation of the date is m/d/yyyy, it is however possible to override this when exporting to excel and specify an alternative format.
Resolution
This issue is resolved through the following local change:
Save the Export_DateTime control which is present in Pega-WB: 06-02-01 in any available application rule set with some custom name and include that name in Export Format field of Listview rule.
After saving that control, modify the code such that, include the existing HTML code in between below div tags
<div class="excel-datetime" style="vnd.ms-excel.numberformat:dd/mm/yyyy HH:mm">
Existing code
</div>
Published January 31, 2016 - Updated October 8, 2020
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