Support Article
Date parsing in the incoming SWIFT Messages does not work
SA-55498
Summary
When parsing dates for incoming SWIFT messages, the date value increases by a day. This occurs when using Pega Smart Investigate for Payments 7.11 application running on Pega 7.2.2.
Error Messages
Not Applicable.
Steps to Reproduce
- Configure a service file with a sample SWIFT message containing dates in the expected format
- Run the case and check the transaction date and the parsed value date
Root Cause
A defect in Pegasystems’ code or rules.
Resolution
Apply HFix-28962.Published April 16, 2018 - Updated December 2, 2021
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