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Support Article

Date time control in Pega Mobile client sets incorrect time

SA-22056

Summary



In a Pega Mobile Client application, the date time control is behaving incorrectly. When a user selects a time between 12:00 – 12:59 P.M., for example 12:20 P.M., the date passed by the mobile application is incorrectly specified as 12:20 A.M, instead of 12:20 P.M.  However, if the date is selected as 12:20 A.M., the application passes the date correctly as 12:20 A.M.


Error Messages



Not Applicable


Steps to Reproduce

  1. Set up a mobile control which uses the mobile devices native date time control.
  2. Using an iPad or Android device, access the datetime control.
  3. Set the time as 12:01 PM.
  4. Observe the time of day sent back to Pega is instead 12:01 AM

Root Cause

This issue is caused by a bug in Pegasystems code.  Pega is incorrectly interpreting the response from the mobile device's native control.

Resolution

Apply HFix-27125 to address this issue.

Published April 13, 2016 - Updated October 8, 2020

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