Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

DateTime Formating not working for report definitions

SA-11916

Summary



In a report definition, if you change the datetime format for a DateTime type property then the time part is getting dropped while Date format is getting updated accordingly.

Error Messages



Not Applicable

Steps to Reproduce

  1. Create report definition with a DateTime property.
  2. Configure that column to show different format of DateTime other than default. 
  3. Run the report.


Root Cause



The root cause of this problem is a defect in Pegasystems’ code/rules. 

Resolution



This issue is resolved by hotfix item HFix-22695. After installing the Hfix need to follow these steps:
  1. Stop the app server.
  2. Delete extract marker file and prgenjava folder.
  3. Restart server.
  4. Regenerate the function GENERATEGRIDHTML--(STRINGBUFFER,429DDD37C5C7E726C74541FA5CF54A75 of Library "Harness" and ruleset "Pega-UIEngine 07-10-16".
Suggest Edit

Published July 8, 2015 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us