Support Article
DB (PEGA0005) Alerts in NBAM framework for PR_DATA_IH_FACT
SA-38859
Summary
Seeing many DB alerts for below query in NBAM framework for below query :
SELECT MAX(Impression) AS Impression, MAX(Clicked) AS Clicked, MAX(Accepted) AS Accepted, MAX(Pending) AS Pending
FROM NBAMEXTERNALO.MKT_INTERACTION_DETAIL
WHERE pycategory in ( 5 recent )
This is invoked from the rule --->RULE-OBJ-ACTIVITY PEGAMKT-WORK-CAMPAIGN GETDASHBOARDSTATISTICS
The activity is OOTB and alerts are seen in AES as well as in logs during dashboard load.
Error Messages
Not Applicable
Steps to Reproduce
Seen in AES and during dashboard load.
Root Cause
These alerts will occur when one of the tables (PR_DATA_IH_FACT) behind the view reaches 50+ million records. This user was seeing 80+ million.
Resolution
Perform the following local-change: incorporate PR_DATA_IH_FACT into the archival strategy to maintain performance.
Tags:
Published June 22, 2017 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.