Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

DB Tables not created in target system



User has imported the application which contains schema tables for custom database tables but the tables are not being created in the database.

Error Messages

Not Applicable.

Steps to Reproduce

Package or export an app on the source server, and import on the target server.

Root Cause

The root cause of this problem is defect or misconfiguration in the operating environment.

The production level of the target system is three, but the SysAdmin4 role only allows import schema changes for production level of two or less.


The explanation for this behavior is as follows: 

Refer to this article it talks about the privileges that are required to automatically perform schema changes within Pega:

By default, the Access of Role of Object rule for the  SysAdmin4 role sets the privileges for ImportSchema to production level of two or less.  

To allow schema changes one must either change the production level to be two or less or change the level of the corresponding privileges in the Access of Role to Object rule for SysAdmin4

If opted to change the production level to do the import then, make sure to clear the conclusion cache In Memory and In Database and then do a JVM restart after the change.  

The other option is to leave the settings as they are and manually create the tables in the database.
Suggest Edit

Published March 9, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us