Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Declare Indexes instances are missing



After running the column populator, some declare indexes instances are removed from the index table.

Error Messages

Not Applicable

Steps to Reproduce

Run the column populator and allow indexing.

Root Cause

The root cause of this problem is software use or operation error. 
Prior to running the column populator, user has updated a Declare Index rule to be based on a new different page (the source page context) which is triggering the issue.

Here is an explantion of this scenario.
The userhas updated his application to use new pages and new Declare Index rules.
Original work items have a page PageA (but not PageB). New work items have a page PageB (but not PageA)
Original Declare Index is using a source called PageA. New Declare Index is using a source called PageB.

When the column populator runs, PRPC deletes and recreates indexes.

For Original work items:
Old indexes are deleted.
PRPC checks for PageB on Original work item but does not find them as it has only PageA so no indexing is taking place. The indexing is lost.

For New work items:
Old indexes are deleted.
PRPC checks for PageB on New work items, finds it and creates indexes.

As a results, indexes have been recreated for New work items but not for Original ones.


PRPC behaves as expected.

This issue is resolved through the following local-changes: 

First solution:
Instead of editing the Declare Index rule which caused the issue, you could have 2 Declare Index rules (mapped to the same Index class): one for the PageA (as per example), the other one for the PageB.
Note: If some work items have both pages, a When condition can be used to prevent one of the Declare Indexes to run, to prevent duplicates.

Second solution:
The issue was triggered because the column populator was run with Declare Index update turned on.
This missing indexes behavior can be avoided if the 
column populator is simply run with Declare Index update turned off (see documentation of column populator on this).



Published November 18, 2015 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us