Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Delete item action not working properly in row repeat

SA-12098

Summary



After upgrading from Pega Platform 6.3sp1 to Pega Platform 7.1.7, you descover that the delete an item action is not working properly in a row repeat. If in a row repeat a user adds two rows and then deletes the first row, and then tries to delete the remaining row the delete action breaks down as the code is passing the wrong index. 

Error Messages



Exception Details

Status fail
Message Index:1. Size: 1


Steps to Reproduce

  1. Create an application with a row repeat in a section using Pega Platform 6.3sp1. 
  2. Migrate the appliation to Pega Platform 7.1.7. 
  3. At run time, add two rows. 
  4. Delete first row and then the second row. 

Root Cause



The add-item link was placed at the top of the row repeat. This causes the PL_INDEX calculation to be incorrect. 

Resolution



This issue is resolved through the following local change: You need to change the position of the add-item link to the end of the row repeat.
Suggest Edit

Published July 13, 2015 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us