Support Article
Dev application performance (Cloud Ticket number - TK-151963)
SA-1349
Summary
Dev application performance issue (Cloud Ticket number - TK-151963)
Developers are noticing sporadic and VERY slow performance on various tasks, including:
- Logging info Developer Portal
- Opening a rule
- Saving / Checking in a rule
Error Messages
2014-08-19 18:32:00,065 [ PegaRULES-Batch-2] [ STANDARD] [ xxxFW:01.01.01] ( internal.access.DatabaseImpl) ERROR - Cannot open the requested instance '': class or class group "" does not exist.
2014-08-19 18:32:00,066 [ PegaRULES-Batch-2] [ STANDARD] [ xxxFW:01.01.01] (e_CLF_ComputeCompliance.Action) ERROR - Error in Obj-Open-By-Handle
com.pega.pegarules.pub.database.BadClassDefinitionException: Class <blank> does not exist
From: (B136800E7786C26222C505376FEB9AC80)
at com.pega.pegarules.data.internal.access.DatabaseImpl.open(DatabaseImpl.java:4577)
at com.pega.pegarules.pub.runtime.AbstractActivity.objOpenByHandle(AbstractActivity.java:121)
at com.pegarules.generated.activity.ra_action_processqueueitem_39dcbbfc875b27faa56fd76076baf9c5.step1_circum0(ra_action_processqueueitem_39dcbbfc875b27faa56fd76076baf9c5.java:345)
at com.pegarules.generated.activity.ra_action_processqueueitem_39dcbbfc875b27faa56fd76076baf9c5.perform(ra_action_processqueueitem_39dcbbfc875b27faa56fd76076baf9c5.java:72)
at com.pega.pegarules.session.internal.mgmt.Executable.doActivity(Executable.java:3265)
at com.pega.pegarules.session.internal.async.agent.QueueProcessor.runActivity(QueueProcessor.java:721)
at com.pega.pegarules.session.internal.async.agent.QueueProcessor.execute(QueueProcessor.java:602)
at com.pega.pegarules.session.internal.async.BatchRequestorTask.run(BatchRequestorTask.java:884)
at com.pega.pegarules.session.internal.PRSessionProviderImpl.performTargetActionWithLock(PRSessionProviderImpl.java:1192)
at com.pega.pegarules.session.internal.PRSessionProviderImpl.doWithRequestorLocked(PRSessionProviderImpl.java:930)
at com.pega.pegarules.session.internal.PRSessionProviderImpl.doWithRequestorLocked(PRSessionProviderImpl.java:829)
at com.pega.pegarules.session.internal.async.BatchRequestorTask.run(BatchRequestorTask.java:617)
at com.pega.jsr166backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:991)
at com.pega.jsr166backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:532)
at java.lang.Thread.run(Thread.java:724)
2014-08-19 18:32:00,104 [ PegaRULES-Batch-2] [ STANDARD] [ xxxFW:01.01.01] ( internal.access.DatabaseImpl) ERROR - Cannot open the requested instance '': class or class group "" does not exist.
2014-08-19 18:32:00,105 [ PegaRULES-Batch-2] [ STANDARD] [ xxxFW:01.01.01] (e_CLF_ComputeCompliance.Action) ERROR - Error in Obj-Open-By-Handle
com.pega.pegarules.pub.database.BadClassDefinitionException: Class <blank> does not exist
Steps to Reproduce
Issue began in the last 24 hours - restart will resume performance for a while but it will recur.
Root Cause
The root cause of this problem is a defect in Pegasystems’ code/rules. A framework activity was queueing items for an agent, but was not populating the queue entry with sufficient data (work object key) to allow for successful processing in the Agent - which led to items stuck in the queue and repeated error messages.
Resolution
This issue is resolved through the following local change: Agent PegaLCLF.ComputeCompliance was temporarily disabled (restoring performance to normal levels), and the issue with the Agent scheduling process is being worked under separate cover.
Published January 31, 2016 - Updated October 8, 2020
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