Support Article
Development system performance degrades
SA-54532
Summary
Performance of the Development environment is slow. Screen-to-screen transition's performance degrades.
Error Messages
PEGA0042
PEGA0001
Steps to Reproduce
- Edit a Rule instance in Pega Designer Studio.
- Select the rule from a list.
Root Cause
ALERT log data indicates that the system is waiting while obtaining the Ruleset list results from the database. The system has multiple rulesets in the Access List from which the user can select the appropriate rule for display. The system must harvest all of the eligible ruleset data from the database, sort/package the results, and return the results to the Rules engine for evaluation.
Resolution
Perform either of the following local-changes:
- Discourage the use of a local ruleset Check-out: If rules are checked in and contained in Locked rulesets, discourage the use of locally checking out a rule for testing. This practice imposes large performance penalties for the user session.
- Unlock the ruleset and modify/test the rule instance to modify a rule instance,
- Ensure that a ruleset is checked in and locked.
- Reduce the number of eligible rulesets in a user’s ruleset list.
- Remove old or unused rulesets if they are still referenced in a user’s ruleset list.
- Use the ruleset Skim feature to bring all eligible rules to a single, current, new ruleset version if rules are distributed throughout a large number of rulesets. As a result, all previous ruleset versions are discarded.
Published March 18, 2020 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.