Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Duplicate pzInsKey created when refreshing a work object

SA-4748

Summary



If you click the refresh option while running a supporting process on an existing work object and then submit the action, a duplicate pzInsKey record is created in the table.

Error Messages



More than one result for pzInsKey "SAMPLE-WORK S-213"; please ensure your database has its pzInsKeys set properly. code: <none> SQLState: <none> Message: <none>


Steps to Reproduce

  1. Open a work object that was previously created
  2. Run a supporting process on the work object
  3. While in the supporting process flow, choose Other Actions => Refresh. Then submit to finish the flow
  4. Try to perform another action on the work object

Root Cause



The root cause of this problem is a defect in customer application code/r
ules.  The work table did not specify pzInsKey as the primary key.


Resolution



This issue is resolved by modifying the work table in the database to specify pzInsKey as the primary key.

Published January 31, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us