Support Article
Duplicate Step in Inflight Cases on addition of new Step
SA-63913
Summary
After adding a new step as the first step of an existing Stage (to the stage rule directly), any inflight cases present in the old first step are displayed and duplicate steps are executed.
New cases work as expected and use the updated step sequence.
Error Messages
Not Applicable
Steps to Reproduce
Add a new step as the first step of the stage directly to either of the following:- Stage rule (if used)
- pyDefault Case Type rule (if separate stage rule is not used)
Root Cause
Processes cannot be reordered directly on the Stage or Case Type rule form.
In this case, the New first step was entered by copying the details of the old first step down to the new step and replacing the first step with the new one. As the inflight case was created before the first step was updated, it used the original and proceeded to the new (now duplicate) step.
Resolution
Perform the following local-change, to add an existing process:
- Add the process to the Stage or Case Type rule as the last step.
- Using the Case Designer to reorder the steps.
Published October 7, 2018 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.