Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

DWA link launched in existing session is not redirecting UI

SA-34306

Summary



Developers are using the Direct Web Access (DWA) feature to implement a Forgot Password functionality. When clicking on the DWA link, the browser is not redirecting the user to the Password capturing screen. Instead it remains on the existing screen.


Error Messages



Not Applicable


Steps to Reproduce

  1. Click Forgot password link configured on a custom Login Page.
  2. Enter the username and move to Question/Answer screen.
  3. On verification of Question/Answer data a DWA assignment is generated and sent over email.
  4. Open the DWA link in same session.


Root Cause



Unable to delete the browser cookies which keep track of the session.

Resolution



Perform the following local-change:
Redirect to Login screen will remove the browser cookie and new session is established when the DWA link in opened.



Published March 15, 2017 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us