Support Article
E-mails are blocked in an application
SA-60779
Summary
Emails are blocked in an application; however, no error message displays in the log files on the web nodes.
Error Messages
[PegaRULES-Batch-88] [STANDARD] [ ] [PegaSample:01.01.01] (pega_integrationengine_default) ERROR - Unexpected exception caught while trying to send an email message with sender ID of <user@pega.com> and addressee of <user@pega.com>:
javax.mail.SendFailedException: Invalid Addresses;
nested exception is: com.sun.mail.smtp.SMTPAddressFailedException: 554 5.7.1 Service unavailable; Client host [127.0.0.1] blocked using localhost; Blocked - see https://localhost/lookup.cgi?ip=127.0.0.1 [rscore=100 ]
at com.sun.mail.smtp.SMTPTransport.rcptTo(SMTPTransport.java:1996)
at com.sun.mail.smtp.SMTPTransport.sendMessage(SMTPTransport.java:1240)
at com.pegarules.generated.SendEmailMessage_071027_BjuZfmThQROwBSK7et3Jsw.SendEmailMessage07_10_27(SendEmailMessage_071027_BjuZfmThQROwBSK7et3Jsw.java:1173)
Steps to Reproduce
Send an email correspondence.
Root Cause
A defect or configuration issue in the operating environment.
Resolution
Perform the following local-change to send emails from the corresponding Pega node. Contact the vendor to unblock the reported IP.
Published July 23, 2018 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.