Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Edit Button does not work in Pega 7.1.8 report browser

SA-19433

Summary



Run a Report Definition and fill in the filters data and click 'Submit'. 

Once you see the report in report viewer the data is empty and when you click on Edit Report button from the report viewer an error message is being displayed as follows:

There has been an issue; please consult your system administrator


Error Messages



There has been an issue; please consult your system administrator


Steps to Reproduce



1. Create the report definition in PRPC 6.2 SP1 version.
2. Upgrade the PRPC 6.2SP1 to v7.1.8. 
3. Execute the report definition. 
4. Observe that you're not able to view the report data in the report viewer and Edit button does not work. 


Root Cause



User has upgraded the PRPC from 6.2SP1 to v7.1.8 and the report definitions were created in 6.2SP1 version. The issue is with the report definitions ruleset version.

Resolution



User revalidated the Report Definition rules to latest ruleset version from the below landing page, 

Designer Studio > System > Release > Upgrade > Validate > Revalidate and save. 
Suggest Edit

Published February 9, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us