Support Article
ElapsedStatusTimeTrend & AveragElapsedTimePerStatus Report hangs
SA-1568
Summary
IE browser hangs when user accessed the reports “Elapsed Status Time Trend” and “Average Elapsed Time Per Status” (second copy) under Case Manager portal.
Error Messages
"WebContainer : 8" Id=276 in RUNNABLE
BlockedCount : 23, BlockedTime : -1, WaitedCount : 21904, WaitedTime : -1
at com.pega.pegarules.exec.internal.util.collections.StringPoolImpl.add(StringPoolImpl.java:256)
at com.pega.pegarules.data.internal.clipboard.ClipboardPropertyImpl.adoptDictionaryDefinition(ClipboardPropertyImpl.java:3112)
at com.pega.pegarules.data.internal.clipboard.ClipboardPropertyImpl.lookupDictionaryDefinition(ClipboardPropertyImpl.java:3152)
at com.pega.pegarules.data.internal.clipboard.ClipboardPropertyImpl.lookupDictionaryDefinition(ClipboardPropertyImpl.java:3035)
at com.pega.pegarules.data.internal.clipboard.ClipboardPropertyImpl.setValueOverride(ClipboardPropertyImpl.java:3782)
at com.pega.pegarules.data.internal.clipboard.ClipboardPropertyImpl.setValueOverride(ClipboardPropertyImpl.java:3592)
at com.pega.pegarules.data.internal.clipboard.ClipboardPropertyImpl.getPageValue(ClipboardPropertyImpl.java:3290)
at com.pega.pegarules.data.internal.clipboard.ClipboardPropertyImpl.getPageValue(ClipboardPropertyImpl.java:3262)
at com.pega.pegarules.data.internal.clipboard.ClipboardPropertyImpl.addToList(ClipboardPropertyImpl.java:1711)
at com.pega.pegarules.data.internal.clipboard.ClipboardPropertyBase.getPropertyValue(ClipboardPropertyBase.java:2387)
at com.pega.pegarules.priv.desktop.reporting.FusionChartDataGeneration.createDateTimeCategories(FusionChartDataGeneration.java:1207)
at com.pega.pegarules.priv.desktop.reporting.FusionChartDataGeneration.fillCategories(FusionChartDataGeneration.java:1243)
at com.pega.pegarules.priv.desktop.reporting.FusionChartDataGeneration.createIntermediatePage(FusionChartDataGeneration.java:622)
at com.pega.pegarules.priv.desktop.reporting.FusionChartDataGeneration.generate(FusionChartDataGeneration.java:584)
at com.pegarules.generated.activity.ra_action_pzcreatechartresults_a443d42d3ff8f2340bb1744b0dfa098c.step10_circum0(ra_action_pzcreatechartresults_a443d42d3ff8f2340bb1744b0dfa098c.java:995)
at com.pegarules.generated.activity.ra_action_pzcreatechartresults_a443d42d3ff8f2340bb1744b0dfa098c.perform(ra_action_pzcreatechartresults_a443d42d3ff8f2340bb1744b0dfa098c.java:280).
Steps to Reproduce
1. Open the Case Manager portal
2. Access "Reports" section and launch either of the following reports:
-Elapsed Status Time Trend - Monitor Process section
-Average Elapsed Time Per Status - Analyze Quality section, second copy
Root Cause
Report “Elapsed Status Time Trend” has an invalid value for the datetime units on the category for the chart. The value was incorrectly set to ‘seconds’ whereas minimum unit must be set to ‘hour’.
Resolution
As a local change, save-as the Elapsed Status Time Trend report in application rule-set and change the unit to ‘Hour’ in the category settings.
Published January 31, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.