Support Article
Email Body is displayed with html tags.
SA-36872
Summary
The user mapped Email Body with Correspondence rule in the Service-Email Response Tab. In the Email, body response is not getting decoded and is displayed with html tags.
Error Messages
Not Applicable
Steps to Reproduce
- Open Service-Email Rule
- In the Service-Email Response Tab, configure Description as Email Body, Map From as Correspondence, Map From Key as Email Response(Correspondence rule) and Save the Service-Email.
- Run the Service-Email Rule, and mention the Subject, From, To Address in the Header Values and Execute the Service.
- In the Service Simulation Results, in the Response Parameter Values, Value is getting displayed with html tags instead of displaying actual body.
Root Cause
A defect in Pegasystems’ rule caused this issue.
Resolution
Apply HFIX-33913 and perform the below steps to resolve the issue.
- Open Service Email rule
- Refresh the Service Email rule
- Select Message Type as HTML in Response tab
Published May 6, 2017 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.