Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Email Body is displayed with html tags.

SA-36872

Summary



The user mapped Email Body with Correspondence rule in the Service-Email Response Tab. In the Email, body response is not getting decoded and is displayed with html tags.


Error Messages



Not Applicable

Steps to Reproduce

  1. Open Service-Email Rule
  2. In the Service-Email Response Tab, configure Description as Email Body, Map From as Correspondence, Map From Key as Email Response(Correspondence rule) and Save the Service-Email.
  3. Run the Service-Email Rule, and mention the Subject, From, To Address in the Header Values and Execute the Service.
  4. In the Service Simulation Results, in the Response Parameter Values, Value is getting displayed with html tags instead of displaying actual body.


Root Cause



A defect in Pegasystems’ rule caused this issue.

Resolution



Apply HFIX-33913 and perform the below steps to resolve the issue.
  1. Open Service Email rule
  2. Refresh the Service Email rule
  3. Select Message Type as HTML in Response tab

Published May 6, 2017 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us