Support Article
Email content is lost when typing an email
SA-57210
Summary
Agents work on email and chat interactions simultaneously. However, when a customer replies in the chat interaction while the agent is typing an email, the email content is lost.
Error Messages
Not Applicable.
Steps to Reproduce
- Log in to the application
- Initiate an email and chat interaction
- Start typing an email and wait for a customer to respond in the chat interaction
Root Cause
A defect in Pegasystems’ code or rules. Each new entry by the chat user resulted in a forced refresh action of the agent's screen (the header). This erased any email text that was entered on the screen and was not yet on the Clipboard.
Resolution
Apply HFix-43130.In addition to the the hotfix, customize the pyReply section rule in the Work-Channel-Triage class to call the new SaveReply activity any time a mouse click occurs within the rich text editor (RTE). Perform the following steps to complete the customization:
- Add Click to the Action list which, as modified by the hotfix, only contains the Change event
- Insert a template and fill in multiple fields by using the mouse to navigate from one field to the next. With this additional change, every time a field is filled in and a mouse click occurs, the change is saved to the Clipboard
Published July 23, 2018 - Updated December 2, 2021
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