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Support Article

Email Listener - The email in POP3 inbox is repeatedly processed

SA-71132

Summary



The Email Listener repeatedly processes an email with a broken image.


Error Messages



Not Applicable


Steps to Reproduce



Not Applicable


Root Cause



A third-party product issue.

When using an exchange server and POP3 protocol, and if the email HTML has invalid references to an image in the email, the following occurs:
  1. An IlligalArgumentException displays
  2. The email is not marked as viewed due to the configuration
  3. The email is read again by the Email Listener

Resolution



Perform the following local-change:
  • Forward unprocessed emails – Select to forward any failed incoming email messages as an attachment to an administrator's email address.

    Scenarios that may cause an incoming message to fail, include:

    - The incoming message size larger than the value set in the Maximum Email size (KB) field of the Email Listener data instance.
    - The incoming message cannot be decrypted.

     
  • Forwarding email address for unprocessed emails – When the previous field is selected, enter the email address to which failed incoming email messages are forwarded. This field supports the Global Resource Settings syntax (=PageName.PropertyName).
This has the effect of removing the invalid email from the mail box and preserve the email for further processing.

For more information, refer to the Help topic, Email Listener form – Completing the Properties tab.


 

Published January 18, 2019 - Updated October 8, 2020

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