Support Article
Email Listener fails to start and does not consider useSSL flag
SA-4417
Summary
Email Listener fails to start due to lack of SMTP port for SSL on Email Server/Account Rule form. By default, enabling 'Use SSL' uses port 465 and you want to specify a custom port viz 780
There is no option to specify this custom port for SSL connection when using SMTP. This causes email listener to fail.
Error Messages
javax.mail.MessagingException: Could not connect to SMTP host: XXXX.XXXX.com, port: 465;
nested exception is:
java.net.ConnectException: Connection refused
at com.sun.mail.smtp.SMTPTransport.openServer(SMTPTransport.java:1391)
at com.sun.mail.smtp.SMTPTransport.protocolConnect(SMTPTransport.java:412)
at javax.mail.Service.connect(Service.java:288)
at javax.mail.Service.connect(Service.java:169)
at com.pega.pegarules.integration.engine.internal.services.email.EmailListener.testConnectionToResponseServer(EmailListener.java:1339)
Steps to Reproduce
Modify Default Email Account form and select use ssl checkbox and do test connectivity. It should fail with the same error:
Data-EmailAccount.Default: MessagingException caught connecting to email server; javax.mail.MessagingException: Could not connect to SMTP host: <IP Address>, port: 465;
Root Cause
The root cause of this problem is a defect in Pegasystems’ code/rules.
Resolution
This issue is resolved by hotfix item Hfix-10427. Email Server now has Advanced tab under where java mail properties can be added for Email Listener to use such as mail.imaps.port or mail.smtps.port
Published January 31, 2016 - Updated October 8, 2020
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