Support Article
Email Listener not processing emails for brief period
SA-11724
Summary
It is observed that Email listener does not process emails for a brief period of time even though the system is running state.
The email listener does not respond and the last access time does not updated. Further none of the emails sent to the mailbox are getting processed.
Error Messages
Log file has belor error for EmailListener:
FATAL EMAIL.CDREmailListener.CDREmailServer|from([email protected])|sub(abc def)|Email|CDRSP|RBC-CM-PRDP-Work-Task|CreateNewWork|A77BAE966CBA29F855D9C4EEFE8CB6C5D CDROperator - The business calendar object could not be found
Steps to Reproduce
Not applicable as this is a intermittent issue with Email listener.
Root Cause
EmailListener is not finding Business Calendar so throwing error and not able to process email.
Resolution
Issue is resolved through local-change:
Create Business Calendar object in your setup. More information on Business calendar refer to the following PDN articles.
http://pdn.pega.com/node/1813
http://pdn.pega.com/node/739
Published November 6, 2015 - Updated October 8, 2020
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