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Support Article

Email Listener not sending case creation ackowledgement email

SA-44092

Summary



An email listener is used to create a case when it receives an email from end user and then sends acknowledgment email with case ID information.

The users observed latency in acknowledgement emails and also some times did not receive at all.

Performance issues in terms of case creation and acknowledgement emails.

This is very sporadic issue.

Error Messages



Exception:
2017-07-31 11:11:14,027 [ EMAIL-Thread-20] [ STANDARD] [ ] [nderwriting:01.01.01] ( services.email.EmailListener) ERROR EMAIL.xxxxxx.Listener|from([email protected])|sub(FW: Crafts) - Caught unexpected ArrayIndexOutOfBoundsException. Will attempt to mark mail as 'seen'.
java.lang.ArrayIndexOutOfBoundsException: message number (350) out of bounds (345)


Steps to Reproduce



An email listener is used to create a case when it receives an email from end user and then sends acknowledgment email with case ID information.


Root Cause



Pega7.2 uses Java Mail 1.5.2 jar and this needs to be updated to Java Mail jar version 1.5.3 or higher where the reported issue has been fixed.

Resolution



Apply HFix-37189

Description of Changes:
​​​​​​​
Upgraded to mail-1.5.5.jar in which the issue got resolved.

Published November 8, 2017 - Updated October 8, 2020

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