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Support Article

Email Response with error sent through Service-Email Rule

SA-17036

Summary



When an Email Listener that uses a Service-Email rule that is configured with a default response message of "None" encounters an error, an email is sent back to the sender that contains the error message.
The error itself is not the issue, the issue is that the sender of the email receives a response with the error even though the default response is configured to be "None".


Error Messages



Not Applicable


Steps to Reproduce

  1. Have an exception in the code which email listener executes.
  2. Keep the service email rule Response tab to have only Default condition and Message Type None.
  3. Have a listener using the above service email rule try to process an email.


Root Cause



Error conditions in service rules will return a standard message if an error is encountered unless that specific error condition is configured on the service rule.


Resolution



To avoid having error responses sent back to the sender, add each of the error conditions on the response tab of the service email rule.

Published January 31, 2016 - Updated October 8, 2020

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