Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Embed section does not render in another class section

SA-86481

Summary



On embedding a section from a different class to the current class, the embedded section does not display on the portal.


Error Messages



Not Applicable


Steps to Reproduce

  1. Embed one section from another class to the current class.

    For example,

    Create a section in the Assign- class and embed it in the data-portal class section.

     
  2. Launch the Case Worker portal.
  3. Click Reports. The embedded section is not visible the first time.
  4. Re-click the 'Reports' link or refresh the portal. The embedded section is visible.


Root Cause



The Embedded section was included through the Clipboard page. Since the embedded page was not available during section rendering, the embedded section was not visible.


Resolution



Perform the following local-change:
  1. Navigate to Cell Properties > Section > General.
  2. Enable the 'Defer load contents' in the Section layout properties.

Published December 2, 2021

Was this useful?

50% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us