Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

On enabling obfuscation WorkArea control throws error



After enabling obfuscation, for a user logged in through Single Sign On(SSO), workarea control does not load and gives an error.

Error Messages

Error 400: Invalid URL used in request 

Steps to Reproduce

Enable obfuscation and then login through SSO to the out of the box user portal.

Root Cause

Both URL Obfuscation and HttpOnly are enabled on the Pega-RULES cookie.
E.g. Set-Cookie: Pega-RULES=H8AC09824EA49703F0237D236F5F49BED; Path=/prweb;Secure;HttpOnly

This is a known limitation with HttpOnly. These two settings aren't compatible with each other.


This is an expected behavior when you have enabled URL obfuscation and you try to use Single Sign On.


Published June 12, 2015 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us