Support Article
Error on adding problem with special character in Troubleshooter
SA-105449
Summary
A problem or a sub problem is added on the Troubleshooter Configuration screen. On entering a '?' (question mark) for the Problem name, uploading a file, and clicking the Submit button, error occurs and the form does not submit.
Error Messages
The Flow Action post-processing activity AddProblem failed: java.lang.RuntimeException: com.pega.pegarules.pub.PRRuntimeException: Illegal characters detected in the path "/StaticContent/datacontent/image/webwb/test problem 32?pro-7520200327t160811.587 gmt.png". You may not use ", ?, *, <, >, |, :
Steps to Reproduce
- On Troubleshooter Configuration screen, click the 'Add problem/sub problem' button.
- In the Form for 'Add problem or subproblem', select a Product name. and enter a value with '?' (question mark) in the Problem field.
- Upload a file.
- Submit the form.
Root Cause
Defect in the PegaKM product.
The below rules are corrected in the PegaKMDiagnostics:08-02-02 ruleset.
RULE-OBJ-ACTIVITY PEGAFW-KM-DATA-TROUBLESHOOTERCONFIGURATIONS ADDPROBLEM
RULE-OBJ-ACTIVITY PEGAFW-KM-DATA-TROUBLESHOOTERCONFIGURATIONS SAVEPRODUCT
RULE-OBJ-ACTIVITY PEGAFW-KM-DATA-TROUBLESHOOTERCONFIGURATIONS EDITPRODUCT
Resolution
Apply HFix-61984.
Published June 2, 2020 - Updated December 2, 2021
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