Support Article
Error login Single Sign-On Missing Relaystate information
SA-53870
Summary
User is having IDP initiated SSO and when user tries to log in they are getting Missing Relaystate error. User added the RelayState parameter into or POST consumer URL but did not work
Error Messages
Missing Relaystate information in IDP Response
Steps to Reproduce
1- Log in into top level application
2- Choose Pega Dev link to login to Pega through SSO
3- Execute :https://servername.com/prweb/PRRestService/WebSSO/SAML/AssertionConsumerService?RelayState=encrypted url
4- Error Unable to process the SAML WebSSO request: Missing Realystate information in IDP Response
Root Cause
A defect or configuration issue in the operating environment. RelayState is getting passed as a query string in the URL .
Resolution
Suggested user to work with the IDP team to pass RelayState tag as a POST body content. After this change the issue is resolved
Published March 21, 2018 - Updated October 8, 2020
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