Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Error login Single Sign-On Missing Relaystate information

SA-53870

Summary



User is having IDP initiated SSO and when user tries to log in they are getting Missing Relaystate error. User added the RelayState parameter into or POST consumer URL but did not work

Error Messages



Missing Relaystate information in IDP Response


Steps to Reproduce



1- Log in into top level application
2- Choose Pega Dev link to login to Pega through SSO
3- Execute :https://servername.com/prweb/PRRestService/WebSSO/SAML/AssertionConsumerService?RelayState=encrypted url
4- Error Unable to process the SAML WebSSO request: Missing Realystate information in IDP Response


Root Cause



A defect or configuration issue in the operating environment. RelayState is getting passed as a query string in the URL .

Resolution



Suggested user to work with the IDP team to pass RelayState tag as a POST body content. After this change the issue is resolved

Published March 21, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us