Support Article
Error message disappears in IE/firefox but stays in chrome
SA-37339
Summary
Inconsistency of Refresh Section Action on different browsers on display of errors message
Issue: When invalid dates are entered in Transaction Post from date and Transaction post to date, system displays error message and disappears in seconds due to “Refresh the section” Action on search button in Visa Claims Resolution (VCR) environment.
Working as expected for Chrome browser. Error message disappears for browsers -Internet Explorer or Mozilla FireFox browsers.
Error Messages
Not Applicable
Steps to Reproduce
1.Add date fields in a section.
2.Add a button with using the path: Run Activity > Refresh - Other Section > Run Activity (date validation is configured)> Refresh - this Section.
3.Run case and provide invalid date value.
4.Click on button.
5.Observe error message stays in Chrome browser but not in Internet Explorer or Firefox browsers.
Root Cause
A defect in Pegasystems’ code or rules. Configure button using:Run Activity > Refresh - Other Section> Run Activity (date validation is configured)> Refresh - this Section, configuration was working in previous Pega 7 as expected in all browsers.
But after upgrade to Pega 7.2.2 , same order in action set works fine only in Chrome browser, that is error message stays in screen but in Internet Explorer or Firefox, it disappears once refresh this section action is over.
Resolution
Perform the following local-change, and change action-set order as:
- -> Run Activity
- -> Refresh - This Section
- -> Run Activity
- -> Refresh - Other Section
Published May 16, 2017 - Updated October 8, 2020
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