Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Error in service - cover case not found

SA-19486

Summary



When calling SOAP-Service which creates new case, receiving below error in logs and call to service fails.


Error Messages



pxGetTopLevelCoverKeyAndClass: No results found when querying for cover information of case EXAMPLE-WORK CASE-123
Problem flow abort due to system flow FlowProblems being the issue


Steps to Reproduce



Call a SOAP service to create a new case.


Root Cause



A defect in Pegasystems’ code or rules. When the pzInsKey of case is empty, pxGetTopLevelCoverKeyAndClass does not gracefully handle the situation and invokes the problem flow.

Resolution



Apply HFix-25827

Published February 15, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us