Support Article
Errors after pre-prod environment refresh
SA-12778
Summary
After refreshing the pre-production environment from a backup of production database, errors are observed and you can no longer use the environment.
Error Messages
Some instances unable to log into, some can log into, but then cant do anything after
** @getClass(Primary)=="Rule-HTML-Harness" null
Unable to synchronize on requestor H15251010AAA5E99EB436E182AFF34937 within 120 seconds: (thisThread = [ACTIVE] ExecuteThread: '6' for queue: 'weblogic.kernel.Default (self-tuning)') (originally locked by = [ACTIVE] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)') (finally locked by = [ACTIVE] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)
<Jul 20, 2015 8:56:05 AM CDT> <Notice> <Stdout> <BEA-000000> <More than one match for package/class com/pegarules/generated.pega_rules_datetime.class returned - ignoring excess>
Steps to Reproduce
Log in to the application and perform refresh.
Root Cause
The root cause of this problem is software use or operation error. The database backup was imported on top of an existing environment, with replace option. It seems like there are still residual fragments of prior environment which cause issues.
Resolution
This issue is resolved by making the following change to the operating environment:
1. Re-export the pegarules schema from the production system.
2. In pre-prod, drop the pegarules schema user entirely. Recreate pegarules user with same privileges as production's pegarules user has.
3. Import the pegarules schema.
4. Truncate cache tables.
5. Redeploy EAR and start system.
Published August 12, 2015 - Updated October 8, 2020
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