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Support Article

EventDetails data transform is null

SA-70746

Summary



EventDetails data transforms are present in Work- defined in the CPMCFW:08-01-01 ruleset and PegaCA-Work defined in PegaAppCA:08-01-01 ruleset. The data transform in PegaCA-Work invokes the super data transform from Work-. Hence, the EventPage is updated to include the following expression,

.CustomerID = @if(Primary.Contact.TargetContactId!="", Primary.Contact.TargetContactId,.ContactId)


The expression does not work correctly for Primary.CustomerID in the New Customer Acquisition case (LocalSalesNegotiator service case, Customer Service for Communications).

Therefore, the CustomerID="Anonymous"; and either of the following properties do not have values,
  • Primary.ContactId
  • Primary.TargetContactId
  • Primary.Contact
As a result, when the EventDetails data transform executes, the CustomerID on the EventPage is set to an empty string and error occurs.


Error Messages



Error from Activity PegaCA-Work -> DefineEventDataFlow (called by Activity Work- CaptureEvent)that runs the Data flow ServiceCaseDSCMF

Java Exception: com.pega.dsm.dnode.api.dataflow.StageException: Exception in stage: Event store

...

Caused by: com.pega.dsm.dnode.api.ExceptionWithInputRecord: com.pega.dsm.dnode.api.ExceptionWithInputRecord: Could not save record: The parameter pxCustomerId is empty


Steps to Reproduce


 
  1. Launch the Interaction Portal for an application that is built on Pega Customer Service for Communication.
  2. Initiate a new Phone Call or Acquisition (Anonymous) call.
  3. Navigate to the Search Customer > General Assistance tab.
  4. Enter data in the Address fields.
  5. Click Check Availability. A New Customer Acquisition (LocalSalesNegotiator) service case is launched.
  6. Select All in the Service Selection screen and enable the Tracer before clicking Submit or Next.
  7. Submit the Service Selection screen. Error occurs in the Tracer on the EventPage step page.


Root Cause



A defect in Pegasystems’ code or rules.


Resolution



Apply HFix-49776.

Published August 19, 2019 - Updated December 2, 2021

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