Support Article
Exception logs for loading the CPM verticalpane
SA-32015
Summary
While starting an Interaction, error observed in logs with Customer Process Manager (CPM).
Error Messages
Developer was getting below errors in the logs.
......
com.pega.pegarules.pub.clipboard.InvalidReferenceException: The reference @(Pega-RULES:Utilities).LengthOfPageList(.RelatedItems)>0 is not valid. Reason: FUAInstance-NullMyStepPage
at com.pegarules.generated.activity.ra_action_caverticallogtaskcompleted_612dc7ae0e0acb4121ed5d49ac9b511b.step5_circum0(ra_action_caverticallogtaskcompleted_612dc7ae0e0acb4121ed5d49ac9b511b.java:673)
at com.pegarules.generated.activity.ra_action_caverticallogtaskcompleted_612dc7ae0e0acb4121ed5d49ac9b511b.perform(ra_action_caverticallogtaskcompleted_612dc7ae0e0acb4121ed5d49ac9b511b.java:143)
at com.pega.pegarules.session.internal.mgmt.Executable.doActivity(Executable.java:3275)
Steps to Reproduce
1. Log into Interaction portal.
2. Create an Interaction.
While interaction is being launched an error is observed in logs.
Root Cause
The error message in the logs is because issue in the activity CAVerticalLogTaskCompleted step 4.
The error is thrown because Step 4 is skipped if the When condition is True and throws the null step page on Step 5.
The reported issue is addressed in CPM 7.1 Release 2 ML 1. Currently developer is on CPM 7.1 Release 2.
So requested them to upgrade to ML 1 or ML 2(recommended - as it contains some extra bug fixes).
Resolution
Developer is requested to update to CPM 7.12.1.
Tags:
Published January 12, 2017 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.