Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

"Exception in requestor maintenance" error in logs

SA-28764

Summary



Errors are seen in the Pega logs when creating a claim case by invoking a custom Pega service. The errors indicate an issue occurred during XML parsing.


Error Messages



2016-09-27 09:40:43,027 [PegaWorkManager : 19] [ STANDARD] [ ] [ PegaRULES:07.10] ( internal.async.Agent) ERROR - Encountered unhandled exception in requestor maintenance
com.pega.pegarules.pub.PRRuntimeException: exception caught during invocation of PRObjectWrapper.prGetObject() for Java Property 
...

Caused by:
java.lang.NullPointerException
at com.pega.pegarules.priv.integration.xml.ParseXMLSAXRuleWrapper.prGetObject(ParseXMLSAXRuleWrapper.java:2321)
at com.pega.pegarules.data.internal.clipboard.ClipboardPageBase.getAttachedJavaObject(ClipboardPageBase.java:824)
... 49 more


Steps to Reproduce



Create a claim case by invoking a Pega service.


Root Cause



A defect in Pegasystems’ code or rules.

Resolution



Perform the following local-change as mentioned in this support article (https://pdn.pega.com/support-articles/parse-xml-not-parsing-soap-response-correctly):
  1. Set the Dynamic System Setting Pega-IntegrationEngine:switchtooldassembler=true
  2. Restart for the change to take effect and test.

Published October 24, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us